A couple of weeks ago I was diagnosed with a


Q: A couple of weeks ago I was diagnosed with a UTI I had the following symptoms.

1: Burning while urinating
2: I had a clear puss white discharge from my penis.
3: I also had a bit of blood in my urine.

The doctor took a swab of the puss discharge from my penis and this was sent to the the lab, they could not find an bacteria or anything. I have to also mention I haven't had sex in about 34 months. The doc prescribed Augmentin antibiotics which I was on for 7 days , which cleared up the infection. I have been off the antibotics for 6 days and woke up this morning with the same Puss discharge from my penis. It does not burn when I urinate and I have use a home urine test to see if there is an infection, but it all seems normal. What could be causing this?

Symptoms:  White Puss From Penis

A:   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: For 10 days I have had a sharp pain in the left side of my penile shaft. I am not sure about the cause. It feel it ...

Q: I was on amoxicillin for a round of that for a sinus infection and a UTI I've now had a cough With some mucus very an...

Q: Hello. I am a 41 y/o woman and have been on yasmin for 8 years. A few months ago i had abnormal discharge and bleedin...

Q: I suffer from recurring UTIs. Tried Nitrofurantoin. Didn't work. Currently on Bactrim -- I am at the beginning of ...

Q: My partner and I have both been tested for gonorrhea. Her test came back positive and mine negative. She said her doc...


Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon