I had my last Depo Provera injection about 7 months


Q: I had my last Depo Provera injection about 7 months ago. I was due to get another shot in December of 2014. I began having brown discharge every day for months (not heavy like a period). It finally stopped at the end of May. From June 2nd to the 8th, I had unprotected sex with my boyfriend every day. I began spotting again a few days ago. Sometimes brown, sometimes red, and sometimes there were clots. I've been experiencing some pregnancy symptoms (nausea, appetite loss, fatigue, etc.). I haven't taken a pregnancy test yet, but I was wondering if the clots and spotting over the past couple of days mean that I'm not pregnant. Please help!


A:   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: I was on amoxicillin for a round of that for a sinus infection and a UTI I've now had a cough With some mucus very an...

Q: Hi, a few days ago i woke up to 2 sets of 2 red inflamed dots under my stomach / in my groin area. To me they looked ...

Q: I am 70 years old and have been suffereing from diarhea for the last few months. Today have got a high reading for ce...

Q: I've spent the the past year or so worrying off and on about lymphoma. Last year, I moved to the Netherlands, by myse...

Q: My 6 year old has a partially white stool. She finished augmentin a week ago for a swollen jaw, which we assumed may ...


Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon