I have had a very mild UTI for over 2


Q: I have had a very mild UTI for over 2 months. I saw a doctor over a month ago and was given acedominophen. I did not notice an improvement. At least twice I have gone for a couple days with no symptoms but then it returns with no warning or reason. The ONLY symptoms I have are either a burning or a dull ache at my urethra exit, and even that is not present at all times. It occasionally burns when I go but not always. There is no abdominal pain, no urge to go, no other problems at all. PLEASE HELP ME!
I should mention that I have been drinking tons of water and tried cranberry juice. I have changed my soap, gone without soap, and changed my toilet paper brand. I know the infection is still there because, besides the discomfort, when I use an Azo home test strip it shows trace LEU and negative nitrite.


A:   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: Hello. I am a 41 y/o woman and have been on yasmin for 8 years. A few months ago i had abnormal discharge and bleedin...

Q: I suffer from recurring UTIs. Tried Nitrofurantoin. Didn't work. Currently on Bactrim -- I am at the beginning of ...

Q: My partner and I have both been tested for gonorrhea. Her test came back positive and mine negative. She said her doc...

Q: Hi- I had a uti, Dr prescribed Bactrim DS 800- (I had awful response- thyroid was swollen,terrible pain in vagina) ...

Q: Hi, I am 39 years old (F), and was doing some moderate house work yesterday. I awoke with a tugging sensation in my b...


Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon