I have had a very mild UTI for over 2

Patient : I have had a very mild UTI for over 2 months. I saw a doctor over a month ago and was given acedominophen. I did not notice an improvement. At least twice I have gone for a couple days with no symptoms but then it returns with no warning or reason. The ONLY symptoms I have are either a burning or a dull ache at my urethra exit, and even that is not present at all times. It occasionally burns when I go but not always. There is no abdominal pain, no urge to go, no other problems at all. PLEASE HELP ME! EDIT: I should mention that I have been drinking tons of water and tried cranberry juice. I have changed my soap, gone without soap, and changed my toilet paper brand. I know the infection is still there because, besides the discomfort, when I use an Azo home test strip it shows trace LEU and negative nitrite.
Doctor :   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: I have a fever on thurday i took advil to prevent and then on friday night I have problem of frequent urination

Q: Looking for only a urologist Dr KUMAR to answer this So as a recap in mid December, she developed an ecoli uti. It...

Q: I think I have a UTI. I am on Accutance 10 mg/per day. Is there a safe antibiotic to take?

Q: 85 year old female. Has ostomy bag (bladder removed 20 years ago). Patient has had chronic UTIs in the last 6 month...

Q: Hi i have been diagnosed with e coli in my urine.I have had problems passing urine and also have a bloated feeling in...

 
DOCTOR ADVISORY BOARD
218

Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician
173

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician
138

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist
98

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon
CNN
BBC
MSNBC
CBS
abcNews
FoxNews