Miss

Patient

Q: I want to know what's wrong. Im a 24 year old female who is sexually active. I have been on the implant for about a year now.

Symptoms:  Itchy vagina over last few days
No period since December 2013 but I do have the implant.
Yesterday had a brownie discharge.
Woke up this morning with a thickish reddy tissue like discharge.
No other pain or cramps. .
Doctor

A:   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: Hi, I have had this on my penis since mid Oct (3 months). It has not been any change in its color or development is ...

Q: I have my period and its like slimy blood clot like i gave birth 16 weeks ago. Is this normal at all its not like a n...

Q: I recently bought a 1 litre water bottle that you drink between 8-1 and then fill up and drink again between 1-6 (I w...

Q: My 19 month old granddaughter was a wonderful eater & now she will barely eat anything? I have started giving her...

Q: I was on birth control last month to get my hormones back in control before trying for a baby again. I took to from D...

 
DOCTOR ADVISORY BOARD
218

Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician
173

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician
138

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist
98

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon
CNN
BBC
MSNBC
CBS
abcNews
FoxNews