Symtoms of UTI but with no bacteria


Q: I have recently had a confirmed uti which was treated with broad spec antibiotics for 7days. this took away symptoms. then i got thrush (as i normally get after antibiotics). I started on thrush cream... however on top of itching i also have the heavy bladder feeling (which i have never had with thrush) and when i do pee i only pee half of what i expected. i have gone Dr 3 more times since... i have had 3 more uti test which were all clear. I have had swabs to test for stds (even tho long term bf), other bacteria, etc i have also had a blood test to check on liver, kidney fucntion etc... all came back ok.

Now itching has gone but i still feel the need to pee.... no one can help.. Any ideas?


A:   This question is currently in queue and will be answered shortly by one of our doctors. In the meantime you may browse our library of answered questions by clicking here.

Related Q&A

Q: Hello. I am a 41 y/o woman and have been on yasmin for 8 years. A few months ago i had abnormal discharge and bleedin...

Q: I suffer from recurring UTIs. Tried Nitrofurantoin. Didn't work. Currently on Bactrim -- I am at the beginning of ...

Q: My partner and I have both been tested for gonorrhea. Her test came back positive and mine negative. She said her doc...

Q: Hi- I had a uti, Dr prescribed Bactrim DS 800- (I had awful response- thyroid was swollen,terrible pain in vagina) ...

Q: Hi, I am 39 years old (F), and was doing some moderate house work yesterday. I awoke with a tugging sensation in my b...


Dr. James Obaji M.D.

  • 247 Reviews
  • Family Physician

Dr. Suneel Sharman M.D.

  • 190 Reviews
  • Family Physician

Dr. Pat Golden M.D.

  • 169 Reviews
  • Cardiologist

Dr. Kunaal Jindal M.D.

  • 112 Reviews
  • Plastic Surgeon